了解iHyperVision是什么

 Top Next

创造智能监控新模式

iHyperVision是一款强大的智能监控软件，集监控、分析与报警于一体，

提供专业的视频监控与报警功能。在这份帮助文档中将详尽的介绍iHyperVision

的各项功能和使用方法，帮助用户快速入门。

开始使用 — 新用户

· 通过学习了解iHyperVision是什么和快速建立iHyperVision系统熟悉该系统的基本功能和配置

· 在iHYperVision系统详细说明和点开其他各项链接中，你将得到关于iHyperVision系统的详尽帮助内容


iHyperVision简介

 Top Previous Next

智能的监控工具

宝信智能视频分析应用软件v2.4(iHyperVision，简称iHV)，是先进可靠、集众多功能为一体、可灵活配置、实施简便的智能监控系统。他集监控、回放、报警、联动、统计等多功能为一体，实现客流统计、入侵检测、人群密度统计、逆行检测为应用的智能监控。该产品从技术、设计、开发、维护等各方面保证系统的先进性，为广大客户提供了完整、全面的视觉监控管理方案。

优秀的产品设计

为满足系统所选用技术和设备的协同运行能力，允许调用不同厂商标准化设备的兼容，从而使设备具有开放性，系统各个组件，都可以根据实际需求分布式部署并加以集中管理，避免了由于媒体流处理的性能压力造成的瓶颈问题，从而可以实现监控规模的无限制扩展。

宝信智能分析应用软件将视频监控及视频分析功能集成一体，再结合报警系统形成完善的系统。对每一台摄像机的画面内，可以设置不同的检测区域，每块检测区域可以同时满足客流统计、入侵检测、人群密度估计、逆行检测的智能分析功能。先进的算法也保证了面对不同复杂环境的仍具备较高的准确性，在改变一个检测区域或规则时仍然能保证良好的工作状态，这是同类产品往往所不具备的。

宝信智能分析引用软件具有灵活的模块管理。不同的用户可以根据指定的权限对系统进行操作。通过监控管理终端，还可以对分布在各区域的子监控终端进行远程的集中管理，用户只需要在一台客户端上就可以对整网设备进行批量配置下发、远程升级、远程操作、视频监控等操作。在数据查看方面，监控管理终端提供了客流统计数据的统计报告，对数据进行了可视化处理，通过图表直观了解各个视频场景的客流情况，提供管理者有力的决策依据。

广泛的行业应用

经过几年的技术积累和创新，iHyperVision在技术上取得了卓越的成绩，智能产品贴合市场需求，并在轨道交通、城市道路、市政工程、工业生产、银行金融系统、智能楼宇、公安司法等多个行业得以应用，获得了用户的广泛好评。


iHyperVision的系统架构

iHyperVision系统架构图


iHyperVision的功能模块

v客流统计：

行人计数或称客流统计，用来统计通道口出入人数，并提供人群流动方向等信息，适用于交通枢纽、机场、车站、商场、超市、连锁店、公园景区、体育场馆、娱乐场所等交通业、零售业、旅游娱乐业和安防领域，可以为用户提供人员数量、滞留人数、人流规律、人数趋势等信息，为管理者提供科学的决策依据。本系统能自动检测和跟踪行人，并据此判断行人进出的方向和数量。将检测得到的行人信息通过网络传输并存储到数据库，以供客户进行各种查询统计操作。

v入侵检测：

入侵检测视频分析功能即针对进入禁入区域的目标进行检测并按照用户设置的规则触发报警。用户可以通过在视频画面中勾勒出预告警机制覆盖的区域，这个区域既可以是规则区域，也可以是不规则区域，视频分析只需在这个区域内进行。一旦有入侵者闯入该区域，即产生入侵报警事件，并在客户端自动显示报警的视频。用户可以根据该报警信息做出相应的管理措施，避免财物损失或其他意外事件发生。

v人群密度：

人群密度估计功能是统计计算设定区域内的人群数量，当指定区域内人数超过预设的阈值时将自动产生报警，提示监控管理人员采取针对性的措施。同时系统拥有先进的算法能将背景中的物体和人群区分开来，减少其他因素的干扰，能检测高密度情况下的人群密度，具有较高的检测准确度。

v逆行检测：

逆行检测分析功能，能准确检测出单向通道内的逆行目标并触发报警。应用于公共自动扶梯、车道、机场、火车、地铁内单向通道或关口的监测与报警。用户可以通过在视频画面中自行设定检测区域和运动方向，一旦有逆行发生，客户端自动显示并记录报警的视频。


iHyperVision给用户带来的优势

给用户带来的优势

?iHyperVision支持国内外各种主流高清录像机，高清的视频画面使得监控效果明显提高。毫秒级的报警触发反应时间，能保证对实时事态做出快速的反应时间。

?实时报警画面弹出提醒，报警信息语音提醒，减少监控人员的劳动强度，只需要关注相关信息，大大提高监控效率。强大的数据检索和分析功能，在海量的视频数据中快速检索到需要的视频。

?支持多路视频回放、数据的统计、多级场景配置和管理员权限分配，灵活实现大规模集中或分布式监控应用。

?模快化的开发方法，在面对需要支持新的需求，或者底层硬件出现变更时，可以在较短发开周期内完成对新设备的支持，大大降低了后期对硬件的维护成本，方便了新功能的扩展。同时，可兼容原有部分监控系统，使得原有的资源得到有效的整合。

?采用普通监控摄像机及其安装方式，可以跟视频监控系统有机集成，既节约成本又方便施工。

?能够实时进行统计和分析，并能根据需要给出适当的报警。可提供日报、周报、月报、季报、年报和自定义报表等客流数据报表。

?客流统计可以同时统计双向（进和出）的客流量，统计误差不超过+/-5%（直行通道）或+/-10%（进出门口）。

?人群密度检测系统对于人群密度估计的准确率高于80%。

?逆行检测运用先进算法，在人群密度较大时，仍有较高的准确率。

?入侵检测准确率高于90%，系统鲁棒性好，可以排除光照变化、阴影、雨雪天气、持续的背景运动物体、摄像机抖动等对入侵检测有较大影响的因素，实现各种复杂场景下准确的入侵检测功能。


iHyperVision用户界面介绍

iHyperVision监控管理用户终端界面

minus 视频报警监控端动画演示

icvclient


如何得到我们的帮助

上海宝信软件股份有限公司


安装iHyperVision

本章将图文详述iHyperVision的安装环境要求，安装步骤及许可证的安装及使用，帮助用户正确安装。安装前请确认自己的服务器部署方案，选择适合的组件进行安装。部署方案请参见案例：服务器部署方案


环境要求

.硬件环境

?摄像机：

客流统计/入侵检测/人群密度估计/逆行检测：支持海康/大华/宇视的数字摄像机，以及其他支持RTSP视频流输出的摄像机

高清人像抓拍检索：仅支持宝信人像抓拍高清智能相机

?录像机：

客流统计/入侵检测/人群密度估计/逆行检测：支持海康/大华/宇视的网络硬盘录像机

高清人像抓拍检索：支持海康/大华的网络硬盘录像机

?智能视频分析服务器：

iHV不包含硬件服务器，建议：

a)每两路功能匹配一个CPU内核，Intel Core i7/Xeon处理器，主频>=2.4G；

b)为使用GPU加速功能，建议NVIDIA显卡，显存>=4GB；

c)内存8GB及以上，64位Windows操作系统；

?监控管理终端：

处理器：>=1.8GHz的奔腾兼容的处理器

内存配置：>=1G

硬盘配置：>=80G

网卡：100M/1000M

显示器：支持分辨率为1024*768及更高分辨率的显示器

.软件环境

?操作系统：

智能视频分析服务器：Windows Server 2008 R2/2012 R2

监控管理终端：Windows XP/Vista/7

.安装环境

?摄像机的安装角度一般跟地面成30~60度，否则影响计数准确度。

?室内光照良好，视频成像清晰，行人轮廓清晰可辨。


安装步骤

安装前注意事项：

iHyperVision.exe安装程序图标如下：

安装iHyerVision请以管理员身份运行，使得程序获得运行权限，避免部分程序无法正确安装。

方式一：右击“iHyperVision.exe”->“以管理员身份运行”。

方式二：右击“iHyperVision.exe”->“属性”->勾选“以管理员身份运行”，如下图所示：

安装iHyerVision:

Ø点击“iHyperVision.exe”，运行iHyperVision安装文件，点击下一步进入安装。如下图：

Ø进入“选择组件界面”，请更具权限选择相关的组件，如下所述：

§报警监控安装包：安装视频监控服务终端，实现视频的监控、报警、统计、配置等功能。

§视频分析安装包（32/64位）：视频分析服务终端，实现对监控视频的运算分析，通过“控制版面”->“系统和安全”

->“系统”，查看计算机的系统类型，根据实际情况选择安装32位或64位操作系统的视频分析安装包。

§web展示安装包：web展示客户端，用于网页浏览统计数据及配置软件。

安装界面如下图所示：

Ø在安装路径设置页面中，点击“浏览”选择要安装的目录如下图所示：

caution 注意：安装目录不可使用中文名及字符，建议安装于C：盘根目录下iHyperVision文件夹内。

点击“安装”，开始iHyerVision的安装。

Ø点击“完成”，结束安装。


许可证的安装与使用

许可证的申请分为公司外部及公司内部两种申请方式，公司外部用户使用的是正式的以Ukey安全狗为介质的硬件许可证，随产品一同交予客户。公司内部使用的是临时许可证，是软件许可证，仅供开发、测试使用。

minus 硬件许可证的申请方法

1、该产品的许可证为硬件许可证，购买时请与产品提供商联系，确定产品授权数：

a.授权服务器的主机数

b.确定申请的授权通道数

2、购买iHyperVision产品后，获得采购中心提供的授权Ukey。

minus 软件许可证申请的方法

通过网页申请内部临时许可证，步骤如下：

1、登陆临时许可证申请平台：http://technet.baosight.com/ci/

2、进入申请页面，选择“申请临时许可证”菜单。

3、在产品名称中选择“iHyperVision”、填入宝信邮箱地址、申请项目名称、分析服务器的MAC地 址，点击提交。

4、确认提交后，许可证文件将以邮件的形式发送到邮箱。

minus 安装Ukey硬件许可证

安装获取硬件许可UKey后,通过以下步骤完成许可证安装：

1、插入Ukey安全狗硬件

2、打开安装包内SafeDogDriver.exe按提示安装相应的驱动程序

3、完成安装，重新启动分析服务程序，验证许可证授权是否生效

minus 安装xml软件许可证

获得软件许可证文件后，通过以下步骤完成许可证的安装：

1、确保文件许可证的文件名为：license.xml

2、将license.xml拷贝至视频分析服务程序安装目录下的VideoAnalystics文件夹内。举例如：

C:\iHyperVision\VideoAnalytics

3、完成安装，重新启动视频分析服务，验证许可证授权是否生效


快速建立iHyperVision系统

   本章目标是以示例的形式向用户展示快速搭建一个完整的C/S（Client/Serve）架构的iHyperVision系统的基本步骤。

   本章所提供的示例，均以演示为目的，更详细的配置使用说明，请参见：iHyperVision详细说明。

快速建立iHyperVision系统

Ø服务器部署方案

Ø配置视频分析服务器

Ø配置视频管理服务器

Ø设置视频分析仪

Ø配置数据库

Ø配置监控客户端


服务器部署方案

在以下的演示案例中将向用户展示由两台服务器组成的C/S架构的iHyperVision高清视觉监控系统，使用大华硬盘录像机作为视频图像的存储媒介。

选用一台性能较高的服务器作为视频分析服务器，在服务器上安装视频分析安装包。此服务器将对采集到的图像视频进行运算分析，根据实际应用需求实现客流量统计、入侵检测、人群密度和逆行检测的视频分析，最终生成视频分析结果。

部署另一台服务器为监控管理服务器，在服务器上安装报警监控安装包。该服务器将对视频分析服务端和监控管理客户端进行统一配置、统一管理，实现一体化集中监控的目的。在该服务器上能对视频分析服务器进行远程设置，设定不同监控区域的监控功能模块，并实时采集分析结果，存储于服务器中。在监控报警客户端上，能对视频实时播放、实时报警、联动组合报警、查询历史报警信息并进行数据统计等功能。

部署方案如下图所示：


配置视频分析服务器

分析服务器是程序的核心计算服务器，对采集到的图像进行计算分析。运行程序前请安装许可证，安装与使用方法请参见：许可证的安装与使用。然后，按以下步骤完成视频分析服务器的配置：

1、运行安装目录下或桌面快捷方式：VideoAnalystic.exe分析服务程序

安装目录举例如：

C:\iHyperVision\VideoAnalytics\VideoAnalystic.exe

2、无ERROR(错误)提示，则表示程序成功运行，其界面如下：


配置视频管理服务器

视频管理服务器作为整个系统的集中管理终端与视频监控报警终端，需要配置的内容如下：

1、视频分析仪配置程序：通过视频分析配置程序，远程配置远程应用服务器。

2、数据库程序：记录和调用数据分析结果。

3、控客户端：集报警、监控、回放、统计等功能为一体的智能监控客户端。


设置视频分析仪

本节将演示如何在视频管理服务器上远程配置视频分析服务器，其中包括添加视频源、设置检测区域、选择区域功能及配置检测功能算法。

minus 运行视频分析配置客户端

运行配置客户端前，请确保视频分析服务器的顺利运行，运行方法请参见：配置视频分析服务器

点击桌面快捷方式 名称为：视频分析配置客户端或安装目录下DeviceConfig.exe运行客户端。

安装目录举例：C:\iHyperVision\ConfigClient\DeviceConfig.exe

minus 建立连接并添加视频源

1、点击连接设备；2、在设备IP中填入分析服务器所在IP地址；3、点击连接，建立和分析服务器的远程连接。

minus 添加视频源并设置视频缩放比例

1、点击视频源设置；2、添加摄像机的视频源URL，设置方法请参见：视频源地址配置说明 ；3、选择缩放比例 默认视频比例为1:1，当视频源图像像素过大时，请选择适合的视频比例，以提高图像的处理速度 ；4、勾选开启的通道；5、点击确定完成视频源的添加。

minus 选择通道并设置检测区域及功能

1、选择视频通道；2、打开视频显示控制；3、在图像画面中设置检测区域，详见：视频分析配置客户端；4、添加远处与近处人体框及进入方向；

5、右击检测区域勾选检测功能。具体设置方法请参见：视频分析配置客户端

minus 设置检测算法

1、点击算法设置；2、在弹出对话框内设置选用算法功能参数。


配置数据库

本小节将演示数据库的配置：来自分析服务器的分析结果等数据将被集中存储与数据库内，以下将介绍如何快速建立数据库、设置数据库表单、建立每日任务计划。

minus 安装PostgreSQL数据库

初始安装

?双击文件postgresql-9.3.2-1-windows.exe开始安装。

?点击【next】，选择安装目录。

?点击【next】，选择数据目录。

?点击【next】，设置数据库超级管理员的密码为postgres。

?点击【next】，设置数据库端口。

?点击【next】，选择语言。

?点击【next】，开始安装，安装完成后点击【finish】按钮出来如下画面。

?点击【取消】，并在弹出的对话框中选择【是】结束安装。

minus 创建用户

1、右击【登陆角色】，点击【新建登录角色】

2、在属性->角色名称内填入用户名称：peoplecount

3、在定义->密码内填入登录密码，默认密码为：peoplecount

4、根据需求在角色权限内赋予用户权限

点击确定完成用户创建

minus 创建数据库及表单

创建数据库

1、右击【数据库】->新建数据库

2、在弹出新建数据库对话框内，在属性->名称内填入数据库名称：peoplecount

3、选择定义，字符编码选择UTF8，表空间为：pg_default，字符排序选择安装时相应的语言项，本例中为：Chinese(Simplified),连接数限制为：-1

4、点击确定，创建名为peoplecount的数据库

导入表单

右击新创建的数据库peoplecount->恢复

导入iHyperVision安装目录下的peoplecount.backup文件

minus 配置数据库表单

1、打开peoplecount数据库->模式->public->数据表下：修改analysers、analysers_va、scene内IP地址为分析服务器所在地址，修改servers内地址为报警监控终端所在地址。

修改表单内的IP地址为相应服务所在的地址。示例如下图所示：

2、保存并退出数据库

minus 配置数据库文件

1、数据库配置文件文件位于安装目录下config文件夹内，文件名为：AlarmConfig.ini以及CountServer.ini。参考文件目录如下：C:\iHyperVision\config\AlarmConfig.ini。修改数据库所在IP地址，填入数据库密码。详见：报警监控服务相关配置文件说明

2、修改postgreSQL践踏端口：修改PostgreSQL安装目录下 举例如： C:\iHyperVision\config\data的postgresql.conf文件。

使用文本编辑器修改如下：

去掉listen_addresses前面的井号“＃”，修改localhost为星号“*”

去掉port = 5432 前的井号“＃” 如下图所示：

minus 创建任务计划（仅客流统计需要）

1、使用文本编辑器编辑安装目录下 举例如C:\iHyperVision\Count\ExeSql.bat的ExeSql.bat文件。确保目录与安装目录相一致，添加数据库密码，与postgresql创建的密码相一致。

2、在键盘上按一下 Windows 徽标键 + R，然后在“运行”对话框中键入 taskschd.msc，打开“任务计划程序”

3、点击右侧“导入任务”，

选择导入定时统计的xml文件，文件位于安装目录下的Count_task文件夹下，举例如：文件目录 举例如：C:\Baosight\iHyperVision\Count\count_task\每10分钟统计.xml ；

点击更改用户或组->输入要选择的对象名称->输入计算名 例如：本机的计算机名称为baosight，则在对话框内填入baosight->点击检查名称，将自动匹配计算机名，点击确定；

在操作相内添加ExeSql.bat文件的路径 举例如C:\iHyperVision\Count\ExeSql.bat。

填入相应计算机名的密码，完成权限验证。

4、按照以上方法依次导入另外几个任务文件。


配置监控客户端

本小节将演示如何运行工程、配置工程及部署工程。

minus 启动AlarmService及CountService

1、使用文本编辑器修改安装目录下 举例为：C:\iHyperVision\config\AlarmConfig.ini config文件夹下的AlarmConfig.ini及CountServer.ini文件。修改数据库服务地址、 数据库名、数据库用户名及密码参与应与实际参数相一致。详见：报警监控服务相关配置文件说明

2、打开安装目录下 举例为：C:\iHyperVision\MonitorServer\alarmservice.exe MonitorServer下的alarmservice.exe和CountServer.exe应用程序。

或者双击打开桌面快捷方式：报警监控服务器和客流统计服务器。

caution 注意：启动请确保视频分析服务软件和数据库软件的顺利运行。

minus 配置报警监控客户端文件

1、用文本编辑器打开报警监控客户端安装目录下 举例为：C:\iHyperVision\executable\VADBCONFIG.ini的VADBCONFIG.ini，修改dbname、PCdbname的IP地址为数据库所在地址，serverip为分析服务器所在地址。修改相应的数据库用户名及密码。详见：报警监控服务相关配置文件说明

minus 运行工程

1、右击“服务管理器”，在兼容性下勾选“以管理员身份运行此程序”，确定应用。

2、运行“服务管理器”，系统将自动运行服务器相关进程。

3、第一次运行需要配置加载工程，具体操作如下：

3.1. 打开服务管理器，点击“工程管理”->“恢复工程”，弹出相应对话框。

3.2. 在工程恢复对话框中选择文件路径为：iHyperVision安装目录\Config\alarmclient.zip 文件，

选择目标目录为：iHyperVision安装目录\projects\alarmclient ，点击“确定”进入下一步。

3.3. 勾选左下角“默认启动最后一次运行的工程”，在工程列表中选择工程：AlarmClient

3.4. 点击“运行工程”来启动iHyperVision的服务进程。运行成功后可以在进程管理中查看是否所以进程已经启动。

minus 配置工程--全局配置

1、运行“配置客户端”程序，并在登录页面中填入配置服务节点IP 是报警监控客户端的配置服务程序运行的主机IP地址和权限服务节点IP 是报警监控客户端的权限服务程序运行的主机IP地址，127.0.0.1即本机IP，初始用户名和密码皆为：admin。

2、签入所以组态画面：点击整体迁出后再点击整体签入完成组态画面的配置。

3、配置摄像机及硬盘录像机：填入大华录像机的IP地址、设备端口号、登录账号及密码；添加对应通道的摄像机。

设置完成后右击视频监控系统，签入设置。

minus 配置工程--服务端配置

1、设置SCADA (Supervisory Control And Data Acquisition)系统，即数据采集与监视控制系统。 IP地址，签出SCADA，在主节点内填入监控管理服务器IP地址，签入配置。

2、完成所有配置后右击added_scadaname1，签入配置。

minus 配置工程--客户端设置

1、在客户端配置下打开added_hminame1，先签出文件，然后修改HMI节点IP，改为监控管理服务器地址，修改完成后签入配置。

minus 部署工程

1、点击系统配置->部署->勾选added_scadaname1及added_hminame1->点击部署，完成整个工程的发布与部署。

minus 运行客户端

1、点击桌面快捷方式运行客户端

客户端使用方法详见：运行客户端程序


iHyperVision详细说明

本章节将更详细的解释iHyperVision系统内的各项功能，帮助用户配置适合自己的iHyperVision系统。建议在配置配置系统前，先通过快速建立iHyperVision，快速搭建起一个系统，再通过本章节的说明，有方向的去配置视频分析、摄像机、录像机、管理权限等相关配置信息。

iHyperVision详细说明

Ø使用iHyperVision视频分析服务端

Ø视频分析配置客户端

Ø视频源地址配置说明

Ø使用iHyperVision监控服务终端

Ø配置客户端程序

ü全局配置

ü服务端配置

ü客户端配置

ü系统配置

Ø运行客户端程序

Ø报警监控服务相关配置文件说明


使用iHyperVision视频分析服务端

本章节将详细介绍分析服务程序应用端和配置端的使用说明。分析服务端是iHyperVision系统中的核心计算分析部分，对拍摄的视频画面进行智能分析，以实现：客流量统计、入侵检测、人群密度估计、逆行检测的等强大功能。


视频分析配置客户端

minus 启动客户端

1、通过双击桌面或开始菜单下快捷方式启动配置客户端，如下图：

成功启动后界面如下：

minus 视频配置客户端图标及菜单栏功能说明

以下图表为DeviceConfigure视频分析配置程序的主要功能按钮的用法和解释：

minus 设置检测区域动画演示

region2

minus 设置人体框及进入方向的动画演示

direction


视频源地址配置说明

智能视频分析（包括行人计数、人群密度估计、入侵检测等）需要从不同途径获取视频源，包括视频文件、图像采集卡、RTSP视频流、硬盘录像机等设备的SDK等，需要采用统一定义的视频源字符串格式供程序正确识别并调用相应的模块。

minus 本地视频文件

格式：file://<视频文件路径>

示例：file://d:/videos/video1.avi

说明：该功能仅用于测试和调试用途。

minus 标准摄像头

格式：cam://<摄像头索引>（从1开始）

示例：cam://1

说明：图像采集驱动需符合VFW(Video For Windows)和V4L(Video for Linux)标准。

minus 标准RTSP视频流

格式：rtsp://<网络视频流地址>

示例：rtsp://admin:admin@192.168.1.8:554/h264

说明：admin:admin表示用户名和密码，没有的话可省略；192.168.1.8:554表示IP地址和端口号，标准端口号554可省略；h264是附加标识。RSTP视频流可来自网络摄像机、视频编码器、硬盘录像机、视频服务器等不同的设备，但不同设备的RSTP流地址表示方法不大一样，具体规格需要从设备厂商获取。

minus SDK开发接口驱动DLL

格式：sdk://<DLL文件主名(去掉扩展名)>/<DLL需要的视频源字符串>

示例：sdk://hvhkdvr/admin:admin@192.168.1.8:8000/realtime?channel=1

说明：程序会加载hvhkdvr.dll并调用其中的接口函数。<DLL文件主名>和<DLL需要的视频源字符串>将根据不同的设备要求陆续制定标准定义，因为这个需要用户手工输入（或者在配置程序中生成）。其中DLL文件名不能跟其他任何DLL文件重名，因此建议都以hv开头表示iHyperVision接口驱动；然后是厂商代号（如hk-海康，dh-大华）；最后是设备代号，如dvr-录像机 cam-摄像机，enc-编码器）。

视频类型 | DLL文件主名
sdk:// | hv | hk | dvr
视频源类型为SDK开发接口驱动DLL | 表示iHyperVision接口驱动 | hk-海康 dh-大华 uv-宇视 | dvr-录像机 cam-摄像机 enc-编码器

minus 海康录像机

DLL需要的视频源字符串格式：

<username:password>@<ip:port>/<realtime>?channel=<channel_index>[&streamtype=<stream_type>][&linkmode=<link_mode>]

示例：

admin:admin@192.168.1.8:8000/realtime?channel=1&streamtype=0

说明：

<username: password>: 访问的用户名和密码，若无可省略

<ip:port>: 设备的IP地址和访问的端口号

<realtime>: 表示访问实时视频信号（录像用playback）

<channel_index>: 视频索引号，一般录像机、编码器都能支持很多路视频。

<stream_type>: 码流类别，0-主码流，1-辅码流，缺省是0

<link_mode>: 连接方式，0-TCP, 1-UDP, 2-Multicast, 3-RTP, 4-RTP/RTSP, 5-RTSP/HTTP, 缺省用0。

minus 大华录像机

DLL需要的视频源字符串格式：

<username:password>@<ip:port>/<realtime>?channel=<channel_index>[&subtype=<sub_type>]

示例：

admin:admin@192.168.1.8:8000/realtime?channel=1&subtype=0

说明：

<username: password>: 访问的用户名和密码，若无可省略

<ip:port>: 设备的IP地址和访问的端口号

<realtime>: 表示访问实时视频信号（录像用playback）

<channel_index>: 视频索引号，一般录像机、编码器都能支持很多路视频

<sub_type>: 码流类别，0-主码流，1-辅码流，缺省是0

minus 宇视录像机

§IMOS协议

DLL需要的视频源字符串格式：

<username:password>@<ip:port>/<realtime>? camcode =<cam_code>

示例：

admin:admin@192.168.1.8:0/realtime?camcode=48-EA-63-03-2A-6E_001

说明：

<username: password>: 访问的用户名和密码，若无可省略

<ip:port>: 设备的IP地址和访问的端口号（端口号为0表示SDK自动分配）

<realtime>: 表示访问实时视频信号

<cam_code>: 摄像机编码，可从录像机或视频管理平台获取

§IPC协议

DLL需要的视频源字符串格式：

<username:password>@<ip:port>/<realtime>[?channel=<channel_index>&streamtype=<stream_type>&streamid =< stream_id>]

示例：

admin:admin@192.168.1.8:0/realtime
说明：

<username: password>: 访问的用户名和密码，若无可省略

<ip:port>: 设备的IP地址和访问的端口号（端口号为0表示SDK自动分配）

<realtime>: 表示访问实时视频信号

<channel_index>: 视频索引号，待扩展，固定值0

<stream_type>: 流类别，0-UDP，缺省为0

< stream_id>: 码流类型，0-主码流，1-辅码流，缺省为0


使用iHyperVision监控服务终端

本章节将详述iHyperVision视频监控服务端的配置方法，通过对全局、服务端、客户端、系统的正确配置，使得用户配置一个切合用户实际应用的智能视频监控系统。在运行客户端程序中我们将介绍监控管理终端的界面介绍及使用方法。


配置客户端程序

配置客户端程序为视频管理监控服务配置了：用户权限分配管理、组态画面的资源管理、

视频摄像头、硬盘录像机的管理、驱动管理、主节点与子节点的权限管理等配置。

配置客户端端的初始启动介绍如下：

minus 启动配置客户端

通过双击桌面快捷方式启动配置客户端，如下图：

minus 登录配置客户端

启动集中配置客户端后，系统打开如下界面：

界面填写介绍如下：

„配置服务节点：此处填写用于作为配置服务器的视频监控管理系统所在设备的IP地址（或该设备的机器名）。

„权限服务节点：此处填写用于作为权限服务器的视频监控管理系统所在设备的IP地址（或该设备的机器名）。

„登陆用户名：欲登陆的用户的账号（大小写敏感）

„密码：欲登陆的账户的密码（大小写敏感）

caution 注意：填写的机器名必须可以被域名解析器成功解析，否则会提示配置错误。

minus 配置客户端界面介绍

集中配置客户端界面如下：

„菜单栏介绍

†点击“系统菜单”后，展开如下图：

Ø点击“重新登录”，则注销当前登录并返回到集中配置客户端登录界面。

Ø点击“退出”，则注销当前登录并关闭集中配置客户端。

†点击“系统视图”后，展开如下图：

Ø取消勾选”全局配置“，则在集中配置客户端中隐藏”全局配置“配置界面

Ø取消勾选”服务端配置“，则在集中配置客户端中隐藏”服务端配置“配置界面

Ø取消勾选”客户端配置“，则在集中配置客户端中隐藏”客户端配置“配置界面

†点击”系统配置“后，展开如下图：


全局配置

本节将详述权限管理、资源管理和视频监控系统管理。在权限管理中配置使用用户的权限分配，根据不同用户角色分配相应的权限；资源管理中将介绍主要介绍组态画面的导入；视频监控管理系统将介绍视频矩阵、视频硬盘录像机和监控摄像头的设定。


权限管理

权限管理用于对用户及其所能进行的各项操作进行授权管理，集成在集中配置系统_全局配置中，打开位置如下：

minus 用户管理

用户泛指使用iCV的各种类型的人，包括各类操作工、管理员、配置工程师、系统维护人员等，要对iCV进行操作、配置、管理和维护都需要有权限，所有的操作都有权限进行控制，所有用户只能进行系统授权的各类操作，而没有权限的操作在系统中是不能进行的。

本章介绍用户管理的功能。主要包括新建、删除、修改用户、为用户选择群组。

用户管理的打开位置如下：

双击菜单树中的“用户管理”，打开“用户管理”界面如下图：

用户列表中列举了系统中的所有用户，一般安装完成后都会自动建立一个admin用户作为初始用户，拥有所有系统默认的权限。用户列表的上方有3个按钮，分别为新建用户、删除用户和修改用户，选中用户即可看到用户的信息，用户信息在屏幕的右半部分显示，包括用户的基本信息以及所属群组信息。

u新增用户

1.点击“新建用户”按钮，或点击“用户列表”区域右键菜单中的“新建用户”，弹出“新建用户”界面，如下图：

2.输入相应信息，点击“确定”按钮，完成用户新建。新建的用户会显示在“用户列表”中。

u选择群组

1.点击“选择群租”按钮，弹出“选择群组”界面，如下图：

2.勾选要选择的群组，点击“确定”按钮，完成群组选择。被选中的群组会显示在右侧的“所属群组”。

u修改用户

1.点击“用户列表”中的某用户，点击“修改用户”按钮，或右键点击“用户列表”中的用户，点击右键菜单中的“修改用户”按钮，弹出“修改用户”界面，如下图：

2.若不需要修改该用户的密码，则直接编辑姓名和描述后，点击“确定”按钮，完成用户修改。

3.若需要修改该用户的密码，点击上图中的“修改密码”按钮，弹出“修改密码”界面，如下图：

4.密码输入完毕后，点击“确定”按钮，完成密码修改。

u删除用户

1.点击“用户列表”中的某用户，点击“删除用户”按钮，或右键点击“用户列表”中的用户，点击右键菜单中的“删除用户”按钮，弹出删除提示，如下图：

2.点击“确定”按钮，成功删除该用户。

„创建、删除、更新用户会记录事件,事件记录可以通过历史事件查询控件进行查看。

minus 群组管理

群组是一个用户组的概念，是指某一类人的集合。一般情况下我们会将具有同样类型身份的人分为一类，定义为一个群组，然后将用户归属到这个群组下，这时候只需要对群组进行授权即可使得群组中的每个用户都拥有群组所拥有的权限，这样可以避免重复对同一类型的用户直接授权。另外，群组还能够表示角色的概念，将所定义好的角色按照群组的方式组织好后，通过赋予用户某一种或多种角色，从而方便地对用户权限进行管理，而当用户身份发生改变时，只需要对用户所属的群组既重新定义一下用户的角色即可实现用户权限的改变，方便管理员进行管理。

本章介绍群组管理的功能。主要包括新建、删除、修改群组、选择用户、配置系统授权项权限和自定义授权项权限。

群组管理的打开位置如下：

双击菜单树中的“群组管理”，打开“群组管理”界面如下图：

群组列表中列举了系统中的所有群组，一般安装完成后都会自动建立一个admingroup群组作为初始群组，拥有所有系统默认的权限。群组列表的上方有3个按钮，分别为新建群组、删除群组和修改群组，选中群组即可看到群组的信息，群组信息在屏幕的右半部分显示，包括群组的基本信息、群组用户、群组的系统权限、群组的自定义权限。

u新增群组

1.点击“新建群组”按钮，或点击“群组列表”区域右键菜单中的“新建群组”，弹出“新建群组”界面，如下图：

†优先级：操作优先级有5个，分别为高高、高、中、低和低低，只作用于视频，大屏等应用。高优先级的权限用户在视频、大屏等模块中可以抢占低优先级权限的用户，实现优先控制设备的功能，比如在操作视频摄像头移动的时候，如果权限低的人正在操作时，权限高的人也要操作，权限低的人的操作会被自动静止，等待权限高的用户操作完成后才能继续。

†群组参数：该参数为预留参数,目前没有具体的作用，可以不填。

2.输入以上属性后，点击“确定”按钮，完成“新建群组”操作。

u选择用户

1.点击“群组列表”中的某群组后，点击“选择用户”按钮，弹出“选择用户”界面，如下图：

2.勾选需要选择的记录，点击“确定”按钮，完成用户选择操作。

u选择系统授权项

1.点击“群组列表”中的某群组后，点击“系统授权项”区域中的“选择授权”按钮，弹出“选择系统授权项”界面，如下图：‘

2.勾选需要的记录，点击“确定”按钮，完成系统授权项选择。

caution 注意，此处的系统授权项均为iCentroView内置的授权项，不可增加、删除、修改。每一个授权项的控制范围，可参考每一个授权项的描述。

u选择自定义授权项

1.点击“群组列表”中的某群组后，或点击“自定义授权项”区域中的“选择授权”按钮，弹出“选择自定义授权项”界面，如下图：

2.勾选需要的记录后，可以对“是否控制”，“是否显示报警”，“是否确认报警”以及其他自定义操作行为进行配置，如下图：

caution 注意：“是否控制”，“是否显示报警”，“是否确认报警”为系统内置的操作行为。

†是否控制：用户是否拥有控制该安全区内的tag点权限。

†是否显示报警：用户是否拥有查看该安全区内的tag点报警的权限。

†是否确认报警：用户是否拥有确认该安全区内的tag点报警的权限。

3.设置完毕后，点击“确定”按钮，完成自定义授权项选择。

u修改群组

1.点击“修改群组”按钮，或点击“群组列表”区域右键菜单中的“修改群组”，弹出“修改群组”界面，如下图：

2.填入各属性后，点击“确定”按钮，完成群组修改。

u删除群组

1.选中某群组，点击“删除群组”按钮，或点击右键菜单中的“删除群组”，弹出删除群组提示，如下图：

2.点击“确定”按钮，完成群组删除

„创建、删除、更新群组会记录事件

„群组增加、删除用户会记录事件；

„群组增加、删除资源会记录事件；

„事件记录可以通过历史事件查询控件进行查看


资源管理

组态画面：指现场中使用的构成现场监控界面的画面，组态画面有不同的组态对象以及相应的脚本构成。

“组态画面”的打开位置如下：

minus 组态画面

已经为用户配置好组态画面，不需要修改另外编辑。使用时只需要先整体签出所有的组态画面，更新IP地址后，整体签入所有组态画面即可。组态画面界面如下：

1、点击整体签出、所有组态画面.bsp文件将被签出，同时IP地址被将更新。

2、点击整体签入，跳出如下对话框：

点击签入，完成组态画面的更新。


视频监控系统

视频配置管理是对视频监控系统进行配置和管理。

minus 视频矩阵配置

添加矩阵

1.通过以下方式弹出“选择设备类型”对话框。

方法一：选中配置主界面左边树型结构的视频服务，右键弹出选项“添加设备”。

方法二：选中某一视频服务，点击“ [image] ”图标。

2.若选中配置主界面左边树型结构下面的“矩阵”，右键弹出选项“添加矩阵”或双击右边列表中的“添加矩阵”记录或右边列表中右键弹出菜单选中“添加矩阵”，则直接跳转到第3步骤，弹出“添加矩阵设备配置”对话框。

3.在下图“添加矩阵设备配置”对话框中，输入信息。信息包括选择设备产品型号、设备名称、IP地址、设备端口、设备描述、控制通道、若矩阵需要进行接连配置，转入步骤3，否则转入步骤4。

扩展参数：可根据具体的设备协议进行配置，如设备的用户名和密码，“admin,12345”。

4.点击“…”按钮，弹出下图“设备接连配置”对话框。在该对话框中进行增删改连接操作，完成矩阵接连配置后，点击“确定”或“取消”关闭对话框。若实际矩阵设备没有接连时，忽略这一步骤。

caution 注意：

增删改连接在点击相应的按钮后即生效。

连接信息会在列表中罗列出来。

在没有选中列表中的任何记录时，“修改连接”、“删除连接”按钮灰化。

在选中列表中的多项记录时，“修改连接”按钮灰化。

5.点击“添加矩阵设备配置”对话框中的“确定”添加矩阵设备，点击“取消”放弃添加，点击“继续添加”添加矩阵设备后回到步骤3进行下一个矩阵设备的添加。

修改矩阵

1.通过以下方式弹出“修改矩阵设备配置”对话框。

方法一：选中配置主界面右边列表需要修改的矩阵记录，右键菜单选择“修改XX”选项。

方法二：选中需要修改的矩阵，点击“ [image] ”按钮

方法三：双击列表中的矩阵记录。

2.在“修改矩阵设备配置”对话框中输入修改信息。信息包括选择设备产品型号、设备名称、IP地址、设备端口、设备描述、控制通道、若矩阵需要修改接连配置，则点击“...”按钮进入矩阵连接配置对话框，具体配置方法请参考添加矩阵设备时的连接配置内容。

3.点击“确定”修改矩阵，点击“取消”放弃修改。

„删除矩阵

1.通过以下方式弹出“确认删除”对话框。

方法一：选中配置主界面右边列表需要删除的矩阵记录，右键菜单选择“删除XX”选项。

方法二：选中需要删除的矩阵，点击“ [image] ”按钮

2.在“确认删除”对话框中，点击“确定”按钮，删除矩阵，点击“取消”按钮放弃删除。

„删除某服务下所有矩阵

1.配置主界面中选择“删除矩阵类型设备”。

2.在“确认删除”对话框中，点击“确定”按钮，删除矩阵，点击“取消”按钮放弃删除。

minus 硬盘录像机配置

硬盘录像机(DVR)的基本功能是将模拟的音视频信号转变为MPEG数字信号存储在硬盘（HDD）上，并提供与录制、播放和管理节目相对应的功能。

„添加硬盘录像机

1.通过以下方式弹出“选择设备类型”对话框。

„方法一：选中配置主界面左边树型结构的视频服务，右键弹出选项“添加设备”。

„方法二：选中某一视频服务，点击“ [image] ”图标。

„方法三：在视频服务列表右键弹出“添加设备”。

„方法四：选中树型结构的视频服务，双击右边列表中的“添加设备”记录。

2.若选中配置主界面左边树型结构下面的“硬盘录像机”，右键弹出选项“添加硬盘录像机”或双击右边列表中的“添加硬盘录像机”记录或右边列表中右键弹出菜单选中“添加硬盘录像机”，则直接跳转到第3步，弹出“添加硬盘录像机设备配置”对话框。

3.在下图“添加硬盘录像机设备配置”对话框中，输入信息，信息包括选择设备产品型号、设备名称、IP地址、设备端口、设备描述。

†扩展参数：可根据具体的设备协议进行配置，如设备的用户名和密码，“admin,12345”。

4.点击“添加硬盘录像机设备配置”对话框中的“确定”添加硬盘录像机设备，点击“取消”放弃添加，点击“继续添加”添加硬盘录像机设备后回到步骤3进行下一个硬盘录像机设备的添加。

minus 摄像头配置

u添加摄像头

1.添加设备

2.若选中配置主界面左边树型结构下面的“摄像头”，右键弹出选项“添加摄像头”或双击右边列表中的“添加摄像头”记录或右边列表中右键弹出菜单选中“添加摄像头”，弹出“添加摄像头设备配置”对话框。

3.在下图“添加摄像头设备配置”对话框中，配置相应的信息。信息包括摄像头名称，逻辑编号(不可编辑)，摄像头描述，摄像头附加信息(是否有云台控制、电镜控制、预置位控制(最大数量配置)、加热器控制、雨刷控制、图片抓拍、画面质量控制、时间回放、远程录像查询、本地录像查询等配置)，抓拍图片属性设置(图片尺寸、位深度等)，设备连接属性设置(可以增删改)。

4.连接配置

†添加连接：

1)“添加摄像头设备配置”对话框中点击“添加连接”，弹出添加摄像头连接配置对话框。

2)选择连接设备（一般为矩阵、硬盘录像机或编码器）和所要连接设备的“物理通道”。勾选“通过该设备控制信号源”表示此摄像头的视频控制经由此连接的设备控制，需要进行云台控制时，此项必选；勾选“从该设备获取实时图像”表示此摄像头的实时图像信息经由此连接的设备发送给要求图像预览的客户端；勾选“从改设备获取历史图像”表示此摄像头的历史图像信息经由此连接的设备发送给要求图像预览的客户端。

3)点击“确定”添加连接，点击“取消”取消添加。

†修改连接：

1)在“添加摄像头设备配置”对话框中选择需要修改的连接，点击“修改连接”，弹出修改摄像头连接配置对话框。

2)点击“确定”修改连接，点击“取消”取消修改。

†删除连接：

在“添加摄像头设备配置”对话框中选择需要删除的连接，点击“删除连接”按钮。在弹出的确认删除对话框中选择“确定”删除连接，选择“取消”取消删除。

5.点击“添加摄像头设备配置”对话框中的“确定”添加摄像头设备，点击“取消”放弃添加，点击“继续添加”添加摄像头设备后回到步骤3进行下一个摄像头设备的添加。


服务端配置

本小节将详述SCADA节点配置、MDI变量配置和驱动配置。


SCADA节点总览配置

u查看和编辑SCADA节点

1.双击SCADA Supervisory Control And Data Acquisition系统，即数据采集与监视控制系统列表中的项，比如：added_scadaname1，右侧属性区域中显示added_scadaname1的配置信息，如下图：

2.点击“签出”按钮后，该区域中除“SCADA逻辑节点名（旧）”字段外，其余字段均可编辑，且在左侧SCADA节点总览列表中，被签出的scada前会有一个绿色小勾，效果如图：

3.各属性编辑

„SCADA逻辑节点名：在“SCADA逻辑节点名”中填入新的节点名，如人民广场站。

„主节点：可以填对应视频监控管理服务器所在计算机名称或者IP地址，如V0B0-180860-4.ccdomain.com或192.168.128.121。

„配置冗余节点：为了预防主节点机器出错导致的停运风险，可以选择勾选“配置冗余节点”来配置一个备用视频监控管理服务器信息，配置方法同主节点。如出现故障时会自动切换，用户并不需要做其他操作。

caution 注意：SCADA主备机IP 对应为两台主机， 而不是一台主机的两个IP，后者会导致服务启动异常

„作为中央权限服务器：勾选后，该SCADA节点作为整个iHyperVision系统的权限中心，该节点上的权限配置将会定期同步到各个SCADA节点中。

caution 注意：进行集中配置时，必须且只能配置一个中央权限服务器。

4.各属性编辑完成后，点击“签入”按钮，在弹出的注释窗口中填写签入注释，点击“签入”按钮，即可完成对scada的编辑和保存工作。如图：


MDI变量配置

MDI变量为多态数字量输入，为来自一个I/O驱动的最多三个输入重组数字量数据，将输入组成一个原始数值，并允许你设置报警限。相对于DI变量只有0和1两个值，MDI的值可以为0到7，共8种值。

minus 配置MDI变量基本属性页

在基本属性页上，用户可配置变量名称、描述等基本属性页上所有显示信息。如下图所示：

„用户可设置进行是否进行扫描，并配置扫描周期。

为了避免丢点现象，如果用户知道设备的数据变化周期，建议将驱动的刷新周期配置为设备的数据变化周期的一半，点的扫描周期配置为数据变化周期的4分之一，如设备的数据变化周期为4000毫秒，那么驱动刷新周期为2000毫秒，点的扫描周期为1000毫秒。

„报警：

用户如果需要对变量进行报警处理，需要勾选“启用报警处理”选项。

„重新报警：

如果配置了重新报警, 当过程变量当前值所在状态发生变化,且该状态设置了报警启用,则触发MDI报警；如果未配置重新报警，而之前报警状态如果为报警的话，则如果对应当前状态仍然为报警（状态可以发生了变化，由一个报警状态变为另一个报警状态）则不产生新报警。

„报警时间死区：

配置报警时间区后，需要报警在一段时间死区内维持报警状态，才触发报警，否则不触发报警。

„报警级别：

范围为0-255。

„扩展参数：

存储类的属性的扩展信息，该扩展信息可完全由用户自定义。典型场景如要配置某个类的属性（亦即tag点）产生报警时自动打开报警链接画面，通过该画面查看报警设备的具体信息，我们可将报警链接的画面（如alarm.bsp）输入到类的属性的扩展参数1中，通过报警列表接口得到报警记录后再通过脚本获取该记录对应的类的属性的扩展参数1（即为alarm.bsp），使用OpenPage "alarm.bsp"即可打开该画面。扩展参数脚本的使用参见报警控件函数帮助手册。

„设备状态：

MDI 变量可由1到3个数字量组成，可以配置8种报警状态。

minus 配置MDI变量编码属性页

在编址属性页上，用户可配置此属性页上所有配置项。配置完毕如下图所示：

MDI 变量可由1到3个数字量组成，每个编址对应到一个数字量。


配置驱动

u添加modbus驱动

1.首先，需要配置好相应的SCADA节点。

2.双击SCADA节点下的驱动配置，进入驱动配置页面，在页面的左上方，可以看到“添加驱动”的按钮，点击添加驱动，弹出可用驱动的选择对话框，在可用驱动列表中，选择modbus驱动所对应的“modbus”，然后单击确定。

3.签出该驱动，点击“配置驱动”按钮

4.弹出modbus配置的主界面

u配置modbus设备

1.选择modbus后点击确定按钮，签出modbus，点击配置驱动按钮，系统弹出配置界面，在设备列表处点击鼠标右键，选择“创建设备”选项，如下图：

2.系统弹出设备配置窗口，填入相关配置项，如下图：

„以TCP方式采集的设备按照以下方式配置

参数说明：

†连接类型：选择TCPClient

†协议类型：选择Modbus/TCP

†设备名称：不能为空，不能以数字开头

†响应超时：连接设备和发送数据的响应超时时间。

†IP地址：欲连接设备的IP。

†备机地址：备设备的IP。

†描述：自定义的设备描述信息。

†端口号：欲连接设备使用的端口号，默认为502

†是否支持多连接：该设备是否支持多连接。

†任务号：同一任务号下的设备消息放在同一个进程中。

†多寄存器命令：勾选时，标识用写多寄存器（或多线圈）命令去实现写单寄存器（或单线圈）

u配置modbus数据块

caution 注意：modbus驱动支持免配块方式，若该设备下没有配置任何块。

1.选中已经配置的设备，在“数据块列表”中点击右键，如下图：

2.选择“创建数据项”，弹出数据块配置界面，如下图：

†名称：自定义的块名。

†轮询周期：扫描数据块的周期。

†相位：轮询周期中的相位。

†地址：设备地址。

ØDO:000000-065535

ØDI:100000-165535

ØAI:300000-365535

ØAO:400000-465535

caution 通过地址来设定类型，不用再配置AI/AO/DI/DO

†任务号：不同任务号的块将使用不同的线程进行采集。

†元素个数：该数据块的长度,即，用户要在数据块中保存的查询记录的最大条数

对于AI、AO，为寄存器个数，最大为125，推荐最大使用120；

caution 注：元素个数填写，不用最大值的意义在于，当如FLOAT类型4个字节跨数据块时，可使用预留的部分进行两个数据块间的调整。数据块长度限制，是由于ModBus协议的通讯包限制为256bit

对于DI、DO，为线圈个数，最大为1000；

†描述：自定义的描述信息。

†元素大小[字节]：用户查询的每条记录的元素大小，

对于AI、AO，为寄存器大小，输入2即可；

对于DI、DO，输入1即可

caution 数据块的长度=元素个数*元素大小。AI和AO类型的元素大小不能小于2。

†设备站号：modbus设备的站号。

3.配置完毕后，点击“确定”按钮，完成数据块配置。

4.配置完毕后，关闭配置界面，将modbus签入则完成配置操作。

u配置modbus变量

„注意：由于MODBUS协议是以寄存器为单位写的，因而双字寄存器拆分使用的变量在一个扫描周期内连续对同一寄存器进行写入会存在遗漏风险。因此保守起见，此种情况下，建议Tag点要配置成只读。以下列举了此情况下的Tag点配置：

†DI/DO变量使用如400001:0、300001:15、DataBlock0:b161；

†AI/IO变量中的8位无符号/有符号整型

†TEXT/BLOB变量起始地址和长度跨字。

„免配块的Tag点设备地址的配置方式：

†DI/DO: 000001、100001、300001:15（300001寄存器的最后1位）、400001:0（400001寄存器的第1位）。

†AI/AO：

Ø8位无符号整型、8位有符合整型：

例如：400001:0、400001:8

400001:0代表取400001的第一字节，400001:8代表取400001的第二字节

Ø16位无符号整型、16位有符合整型：

例如：400001，读取一个完整400001寄存器

Ø32位无符号整型、32位有符合整型、单精度浮点型：

例如：400001，表示读取400001和400002两个寄存器

Ø双精度浮点型：

例如：400001，表示读取400001和400004四个寄存器

†TEXT/BLOB:起始地址#长度（字节）

例如：400001#16，表示从400001开始读取16个字节。

„配块方式变量配置：

†AI变量/AO变量配置：

设备地址格式为：数据块名:B偏移量。（B代表以字节为单位进行偏移）

例如：Datablock0:B23，表示从数据块Datablock0中的第24字节开始读取，读取的长度根据AI变量的数据类型自动选取，8为整形则读取1个字节，16位整形读取2个字节，32位整形和单精度浮点型读取4个字节，双精度浮点型读取8个字节。

†DI变量/DO变量的配置：

设备地址格式为：数据块名:b偏移量。（b代表以位为单位进行偏移）

例如：Datablock1:b61，表示读取数据块Datablock0中的第62位。

†TEXT、BLOB：

设备地址格式为：数据块名:偏移字节#字节长度

例：DataBlock0:2#50

表示从数据块DataBlock0的第3字节开始读取50字节的长度。


客户端配置

minus 新增HMI节点

1.右键点击HMI节点总览，选择新增，如下图所示：

2.系统将自动生成一个HMI节点（如：名称为added_hminame1）在HMI节点总览下面，如下图所示：

3.双击新增的HMI节点，如added_hminame1，在右边的HMI通用属性和画面列表中配置HMI信息，如下图所示：

minus 配置HMI节点

caution 注意：

1.要编辑HMI节点的属性，需要先将HMI节点签出，此时签出的hmi节点钱会出现一个打钩的符号。

2.要成功保存HMI节点的属性，需要将HMI节点编辑后进行签入。

3.要是的HMI节点属性生效，需要对HMI节点进行部署。

1.通用属性

通用属性用于配置HMI节点IP、名称、超时锁定时间、超时注销时间、窗口大小以及访问哪几个SCADA节点的服务。

双击HMI节点（如：名称为added_hminame1）或右键点击HMI节点added_hminame1，选择属性，显示HMI通用属性界面如下：

uHMI节点基本属性

„HMI节点IP：HMI节点的IP地址或域名。

„HMI节点名称：自定义的HMI节点名称。

„超时锁定时间：超过设置时间后，运行客户端自动锁定。

„超时注销时间：超过设置时间后，运行客户端自动注销。

„时间同步误差范围：在设置的误差范围内，客户端和服务端不进行时钟同步。

u窗口大小设置：

„手动设置：勾选手动设置后，可以自己填写窗口尺寸，按照设置的尺寸显示运行客户端的大小。

„窗口尺寸：勾选手动设置后方可编辑，用于设置运行客户端的宽和高。

u显示模式设置：

„模式选择：

1.选择不变，运行客户端显示在显示器的左上角。

2.选择居中，运行客户端按照设置的基准分辨率居中显示。

3.选择拉伸，运行客户端按照设置的基准分辨率拉伸显示

„基准分辨率：

1.在模式选择“居中”时，用于计算运行客户端居中的位置。

2.在模式选择“拉伸”时，用于计算运行客户端拉伸的大小。

u登陆设置

„组态登陆：

„登陆界面：运行客户端时，首先打开的是默认的用户登录界面。

„缺省用户登陆：运行客户端时，使用预设的账号登陆，并打开自定义的初始画面。

„自定义画面：运行客户端时，匿名打开自定义的初始画面。

„框架登陆：针对还在使用5.2的客户端的用户使用，在5.5中不需要选择该选项。

uHMI节点访问SCADA配置

点击“添加”按钮，可以选择SCADA，勾选的SCADA会被关联到HMI中。

caution 注意：

1.只有被选择的SCADA上配置的信息才能在HMI上显示。

2.HMI运行时使用的权限服务器为置顶的SCADA节点。

u快捷键显示配置

„F7键限制：在客户端运行时，不可使用F7按键退出到组态编辑。

„ALT+F4键限制：在客户端运行时，不可使用ALT+F4按键关闭运行客户端。

„WIN键限制：在客户端运行时，不可使用windows键打开开始菜单。

„ALT+TAB键限制：在客户端运行时，不可使用ALT+TAB键进行运行程序切换。

u消息中心

„显示报警信息：若勾选，在客户端运行时，会显示悬浮的报警提示。

„显示联动事件：若勾选，在客户端运行时，会显示悬浮的联动事件提示。

caution 注意：若都不勾选，则不会显示悬浮提示。

u选取初始启动画面

通过选取初始启动画面列表中的复选框来选择作为初始启动画面的画面，被勾选的画面会在客户端运行时自动打开，如下图：


系统配置

minus 部署工程

部署指的是将工程运行所需的数据以及相关信息部署到iHyperVision工程中配置的SCADA节点、HMI节点以及WEB节点。

“部署”的打开位置如下：

按照以下步骤可以完成部署操作：

1.点击“部署”，弹出“部署”界面，如下图所示：

列表说明如下：

„名称：节点名称，与SCADA节点、HMI节点以及WEB节点中配置的名称相同。

„节点类型：分别为SCADA节点、HMI节点以及WEB节点 。

„是否主节点：该列只有SCADA类型的节点才有值，为“是”标志该节点为主节点，为“否”标志该节点为冗余节点。

2.勾选节点列表中需要部署的记录（或勾选全选），如下图：

3.点击“部署”按钮，开始进行节点部署。若勾选了SCADA节点 ，则会出现如下提示信息：

„若选择是，则在部署完毕后会对SCADA节点进行刷新。

„若在部署前勾选了“强制部署”复选框，则在部署时不进行文件新旧比较，而直接把所有需要部署的文件全部拷贝到目标节点。若不勾选，则在部署时会判断当前部署的文件是否进行过修改，若没有进行修改，则不拷贝到目标节点。

4.部署的执行结果如下图所示：

部署完成后，会在“进度”界面中显示“部署全部完成！”。分割线以下是通知刷新的结果。


运行客户端程序

minus 启动运行客户端

用户可以通过双击桌面快捷方式启动，如下图：

minus 登陆运行客户端

启动集中配置客户端后，系统打开如下界面：

填入登录用户名和用户名对应的密码，点击确定按钮，若信息正确，则打开运行客户端。

成功登陆后界面如下：

minus 视频画面布局

1、修改视频窗口显示数量

运行客户端后默认显示的是2X2的4格视频画面，通过修改 [image] ，修改客户端的视频显示窗口数。

2、合并视频显示窗口

勾选“支持窗口合并”项 [image] ，左击拖动鼠标，框选所需要合并的窗口。

3、选择视频通道

选中所需显示的视频窗口，被选中的窗口会以绿色框表示。在摄像机下拉菜单下选择相应视频通道，即可显示。下图演示了合并窗口后的“视频通道1”的视频画面：

minus 客流统计

1、点击视频管理监控端上的 [image] 按钮，进入客流统计界面。

2、进入客流统计界面，点击 [image] 选择需要查询的日期。

3、通过右侧门道列表，选择需要查询的视频通道。点击选择视频通道，点击 -> 按钮添加通道。反相选择，点击 <- 按钮，删除选择的通道。通道选择界面如下：

4、在数据类型中，筛选需要显示的统计信息，分别为：进入人数、出去人数和滞留人数。其中滞留人数为进入和出去人数之差。数据类型选择如下：

5、点击 [image] 将绘制所选视频通道和相关数据类型的人数统计表。纵向为统计的进（出）人数、横向为从0点到24点的时间。

minus 历史报警

1、通过点击 [image] 按钮，进入，历史报警视频查询界面。

2、报警时间查询方式分为两种：通过下拉菜单快速查询近24小时内的报警信息快速查询及任意时段查询，查询方式如下图：

3、历史报警查询可以通过报警类型及报警视频通道来筛选报警信息。通过点击打开下拉菜单进行选择：

4、点击 [image] 查询按钮，按筛选条件查询历史报警视频，双击相应的报警信息即可查看报警视频。打开后界面如下：

minus 视频回放

1、通过点击 [image] 按钮，进入历史视频查询界面。与历史报警不同的是，视频回放通过时间筛选查询任意时段内的历史视频信息。

2、点击下拉菜单 [image] ，选择需要查询的摄像头通道。

3、修改开始时间和结束时间，选择需要查询的时间段

4、勾选 [image] ，使该时间段内的视频无限循环播放。

5、点击 [image] 播放视频，点击 [image] 停止播放。

minus 报警提醒

系统会实时提醒报警信息。如果产生报警，会自动弹出对话框，显示当前的报警信息视频，勾选“下次不再弹出”，取消自动弹出窗口功能。报警提醒界面如下：

minus 配 置

1、点击 [image] 按钮，打开配置界面。在配置界面中可以快速配置视频通道和分析仪的IP地址及其名称。

2、通过下拉菜单选择配置模式：

3、点击 [image] 添加新的配置信息，通过点击 [image] 删除选中的配置项。点击 [image] 按钮，刷新列表。

4、双击列表即可修改信息。配置界面如下：


报警监控服务相关配置文件说明

minus 连接报警监控服务器与数据库

VADBCONFIG.ini文件是报警监控端的配置文件，告诉了报警监控程序访问数据库的IP地址、用户名和密码。

VADBCONFIG.ini文件位于报警监控客户端安装目录下的iHyperVision\executable\文件夹内，如果没有该文件，可以在executable文件夹下手动创建，或者运行一遍客户端程序自动生成。

使用文本编辑器编辑配置配置文件如下：

dbname=168.2.9.102@peoplecount:

表示数据库Ip地址为(168.2.9.102)及其数据库名称peoplecount

username=peoplecount:

表示数据访问用户名是peoplecount

password=peoplecount:

表示数据访问密码是peoplecount

serverip=168.2.9.102:

表示报警监控服务器所在IP地址

PCdbname=168.2.9.102@peoplecount:

表示客流统计数据库IP地址（168.2.9.102）及数据库名称peoplecount

PCusername=peoplecount:

表示客流统计数据库用户名是peoplecount

PCpassword=peoplecount:

表示客流统计数据库密码是peoplecount

minus 连接分析服务器与数据库（客流统计）

CoutServer.ini这个配置文件告诉了分析服务器去何处读写数据库，读写客流统计相关数据。该文件位于Baosight\iHyperVision\config文件夹下，用文本编辑器打开如下：

DB_SERVER_IP：数据库服务器IP

DB_NAME：数据库名

DB_USER_NAME：登录数据库用户名

DB_PASSWORD： 登录数据库密码

minus 连接分析服务器与数据库（入侵检测、人群密度和逆行检测）

AlarmConfig.ini这个配置文件告诉了分析服务器去何处读写数据库，读写人群密度、入侵检测和逆行检测相关数据。该文件位于Baosight\iHyperVision\config文件夹下，用文本编辑器打开如下：


配置小工具

人群密度训练分类器

用户可以通过人群密度训练分类器训练符合实际应用场景的分类器文件，使用合适的分类器文件将保证人群密度的统计准确率。

Ø人群密度类型的选择：

人气密度训练分类器分为两种类型模式： 1、以人数的形式显示当前区域内的统计人数值。 2、以密度等级的形式显示，等级分 为：低、较低、中、较高、高。画面上对应1~5五个数值。

在对应的视频通道中，打开，算法设置->人群密度->人群密度类型，根据实际情况选择对应的人群密度类型。（当画面区域中一般 情况下出现的人数较多较为复杂的时候，建议使用密度等级显示；当出现人数易于直观计算，情况较为简单时，建议使用人数的方式显 示。）

设置方式如下图所示：

Ø人群密度训练分类器的使用方法：

打开下拉菜单项，配置->人群密度训练分类器，如下图所示：

根据已经选择的显示类型训练样本，以人数为显示类型为例：

打开视频显示控制，观察当前区域内出现人数，在人数栏内填入实际人数，然后点击采集当前样本，如果采集人数与实际情况不符，可点击撤消上个样本撤消，点击清除所以样本将清除所有已采集的样本。用户可以给训练器样本自行命名，例如图上所示，Camera03指第三通道的摄像头，PeopleCount指显示类型为人数，001为分类文件编号。已采集样本数将在右上角显示，当采集样本大于10个方可开始训练。采集的样本涵盖的情况越多，训练的结果将越准确。该训练器支持断点继续训练，只要不关闭视频分析服务程序，训练样本将自动保存于程序内。

采集一定量的样本后，点击开始训练，训练器将自动生成分类器文件。在算法设置，模型文件下，选择适合的训练器文件。


常见问题与解答FAQ

无。


常见错误代码

 Top Previous

视频分析仪错误代码： 142000 ~ 142999
视频分析仪主模块：142001 ~ 142099 |  | 报警服务器模块：142501 ~ 142509
错误代码 | 含义 | 错误代码 | 含义
142001 | 打开临时文件失败 | 142501 | 内存分配失败
142002 | 打开许可证文件失败 | 142502 | 无效参数
142003 | 视频通道号超出范围 | 142503 | SQL错误
142004 | 检测区域顶点数超出范围 |  |
142005 | 点坐标为负数 |  |
142006 | 设置注册表IP地址失败 | 计数服务器：142601 ~ 142699
142007 | NTP服务器名称不正确 | 错误代码 | 含义
142008 | 设置设备时间失败 | 142601 | 连接数据库失败
142009 | NTP对时失败 | 142602 | 数据库操作出错
142010 | 许可证验证失败 | 142603 | 数据库中找不到对应IP的Server ID
142011 | RTSP视频解码初始化失败 | 142604 | Gate ID不存在
142012 | RTSP视频解码创建失败 | 142605 | 保存计数信息失败
142013 | 视频文件打开失败 | 142606 | 打开配置文件失败
142014 | 摄像机编号设置不正确 | 142607 | 打开无效配置文件
142015 | 摄像机打开失败 | 142608 | 服务器IP未找到
142016 | SDK视频源名称不正确 | 142609 | LogC获取分类错误
142017 | SDK驱动文件加载失败 | 142610 | 数据库未连接
142018 | SDK驱动函数获取失败 |  |
142019 | SDK视频设备初始化失败 |  |
142020 | SDK视频设备创建失败 |  |
142021 | 两次获取的视频图像尺寸不一致 |  |
142022 | 视频通道数超出范围 |  |
142023 | 检测区域数超出范围 |  |
142024 | 录像文件已经播放完毕 |  |
142025 | 视频源前缀不正确 |  |
142026 | 视频帧获取失败 |  |
142027 | 视频缩放比例超出范围 |  |
142028 | 视频通道号发送失败 |  |
142029 | 视频发送JPEG编码失败 |  |
142030 | JPEG文件大小发送失败 |  |
142031 | JPEG文件发送失败 |  |
142032 | 视频发送线程异常退出 |  |
142033 | 命令处理回复信息发送错误 |  |
142034 | 命令处理线程异常退出 |  |
142041 | 检测区域号超出范围 |  |
142042 | 检测区域号不匹配 |  |
142043 | 视频通道号找不到 |  |
142044 | 检测区域号找不到 |  |
142045 | 视频分析配置根节点未找到 |  |
142046 | 加载配置文件失败 |  |
142047 | 保存配置文件失败 |  |
142048 | 新增XML节点失败 |  |
142051 | DLL文件加载失败 |  |
142052 | DLL函数获取失败 |  |
142053 | 视频源错误 |  |
142061 | 该进程已经启动 |  |

客流统计模块：142101 ~ 142199 |  | 入侵检测模块：142201 ~ 142299
错误代码 | 含义 | 错误代码 | 含义
142101 | 打开临时文件失败 | 142201 | 打开临时文件失败
142102 | 打开许可证文件失败 | 142202 | 打开许可证文件失败
142103 | 视频通道号超出范围 | 142203 | 点坐标为负数
142104 | 计数区域顶点数超出范围 | 142204 | 设置注册表IP地址失败
142105 | 点坐标为负数 | 142205 | NTP服务器名称不正确
142106 | 设置注册表IP地址失败 | 142206 | 设置设备时间失败
142107 | NTP服务器名称不正确 | 142207 | NTP对时失败
142108 | 设置设备时间失败 | 142208 | 许可证验证失败
142109 | NTP对时失败 | 142211 | RTSP视频解码初始化失败
142110 | 许可证验证失败 | 142212 | RTSP视频解码创建失败
142111 | RTSP视频解码初始化失败 | 142213 | 视频文件打开失败
142112 | RTSP视频解码创建失败 | 142214 | 摄像机编号设置不正确
142113 | 视频文件打开失败 | 142215 | 摄像机打开失败
142114 | 摄像机编号设置不正确 | 142216 | SDK视频源名称不正确
142115 | 摄像机打开失败 | 142217 | SDK驱动文件加载失败
142116 | SDK视频源名称不正确 | 142218 | SDK驱动函数获取失败
142117 | SDK驱动文件加载失败 | 142219 | SDK视频设备初始化失败
142118 | SDK驱动函数获取失败 | 142220 | SDK视频设备打开失败
142119 | SDK视频设备初始化失败 | 142221 | 两次获取的视频图像尺寸不一致
142120 | SDK视频设备打开失败 | 142231 | 计数数据发送失败
142121 | 两次获取的视频图像尺寸不一致 | 142232 | 数据发送线程异常退出
142122 | 计数区域顶点数不正确 | 142233 | 视频通道号发送失败
142123 | 检测区域数超出范围 | 142234 | 视频发送JPEG编码失败
142124 | 计数区域未设置 | 142235 | JPEG文件大小发送失败
142125 | 进入方向箭头未设置 | 142236 | JPEG文件发送失败
142126 | 远处人体框未设置 | 142237 | 视频发送线程异常退出
142127 | 近处人体框未设置 | 142238 | 命令处理回复信息发送错误
142128 | 人体框设置不正确 | 142239 | 命令处理线程异常退出
142129 | 计数区域设置不正确 | 142241 | 视频通道号找不到
142131 | 计数数据发送失败 | 142242 | 视频通道号超出范围
142132 | 数据发送线程异常退出 | 142243 | 检测区域号找不到
142133 | 视频通道号发送失败 | 142244 | 检测区域号超出范围
142134 | 视频发送JPEG编码失败 | 142245 | 检测区域号不匹配
142135 | JPEG文件大小发送失败 | 142246 | 检测区域数超过范围
142136 | JPEG文件发送失败 | 142247 | 计数区域顶点数超出范围
142137 | 视频发送线程异常退出 | 142248 | 视频分析配置根节点未找到
142138 | 命令处理回复信息发送错误 | 142249 | 加载配置文件失败
142139 | 命令处理线程异常退出 | 142250 | 保存配置文件失败
142141 | 检测区域号超出范围 | 142251 | 新增XML节点失败
142142 | 不能设定两个检测区域 | 142252 | 许可的通道数不够
142143 | 视频通道号找不到 | 142261 | 无效的图像指针
142144 | 检测区域号找不到 | 142262 | 打开配置文件失败
142145 | 视频分析配置根节点未找到 | 142263 | LogC初始化错误
142146 | 加载配置文件失败 | 142264 | LogC获取分类错误
142147 | 保存配置文件失败 | 142265 | 无效的网络命令
142148 | 新增XML节点失败 |  |
142151 | 许可的通道数不够 |  |
142152 | 创建TrackerAuto失败 |  |
142153 | 创建VideoCap失败 |  |
142154 | 头肩检测分类器加载错误 |  |
142155 | XML节点未找到 |  |
142156 | 分类器文件名太长 |  |
142157 | 分类器文件不存在 |  |
142158 | 初始化Tracker失败 |  |
142161 | 该进程已经启动 |  |
人群密度模块：142301 ~ 142399 |  | 逆行检测模块：142401 ~ 142499
错误代码 | 含义 | 错误代码 | 含义
142301 | 打开临时文件失败 | 142401 | 打开临时文件失败
142302 | 打开许可证文件失败 | 142402 | 打开许可证文件失败
142303 | 点坐标为负数 | 142403 | 点坐标为负数
142304 | 设置注册表IP地址失败 | 142404 | 设置注册表IP地址失败
142305 | NTP服务器名称不正确 | 142405 | NTP服务器名称不正确
142306 | 设置设备时间失败 | 142406 | 设置设备时间失败
142307 | NTP对时失败 | 142407 | NTP对时失败
142308 | 许可证验证失败 | 142408 | 许可证验证失败
142311 | RTSP视频解码初始化失败 | 142411 | RTSP视频解码初始化失败
142312 | RTSP视频解码创建失败 | 142412 | RTSP视频解码创建失败
142313 | 视频文件打开失败 | 142413 | 视频文件打开失败
142314 | 摄像机编号设置不正确 | 142414 | 摄像机编号设置不正确
142315 | 摄像机打开失败 | 142415 | 摄像机打开失败
142316 | SDK视频源名称不正确 | 142416 | SDK视频源名称不正确
142317 | SDK驱动文件加载失败 | 142417 | SDK驱动文件加载失败
142318 | SDK驱动函数获取失败 | 142418 | SDK驱动函数获取失败
142319 | SDK视频设备初始化失败 | 142419 | SDK视频设备初始化失败
142320 | SDK视频设备打开失败 | 142420 | SDK视频设备打开失败
142321 | 两次获取的视频图像尺寸不一致 | 142421 | 两次获取的视频图像尺寸不一致
142331 | 计数数据发送失败 | 142431 | 计数数据发送失败
142332 | 数据发送线程异常退出 | 142432 | 数据发送线程异常退出
142333 | 视频通道号发送失败 | 142433 | 视频通道号发送失败
142334 | 视频发送JPEG编码失败 | 142434 | 视频发送JPEG编码失败
142335 | JPEG文件大小发送失败 | 142435 | JPEG文件大小发送失败
142336 | JPEG文件发送失败 | 142436 | JPEG文件发送失败
142337 | 视频发送线程异常退出 | 142437 | 视频发送线程异常退出
142338 | 命令处理回复信息发送错误 | 142438 | 命令处理回复信息发送错误
142339 | 命令处理线程异常退出 | 142439 | 命令处理线程异常退出
142341 | 视频通道号找不到 | 142441 | 视频通道号找不到
142342 | 视频通道号超出范围 | 142442 | 视频通道号超出范围
142343 | 检测区域号找不到 | 142443 | 检测区域号找不到
142344 | 检测区域号超出范围 | 142444 | 检测区域号超出范围
142345 | 检测区域号不匹配 | 142445 | 检测区域号不匹配
142346 | 检测区域数超过范围 | 142446 | 检测区域数超过范围
142347 | 计数区域顶点数超出范围 | 142447 | 计数区域顶点数超出范围
142348 | 视频分析配置根节点未找到 | 142448 | 视频分析配置根节点未找到
142349 | 加载配置文件失败 | 142449 | 加载配置文件失败
142350 | 保存配置文件失败 | 142450 | 保存配置文件失败
142351 | 新增XML节点失败 | 142451 | 新增XML节点失败
142352 | 许可的通道数不够 | 142452 | 许可的通道数不够
142361 | 无效的图像指针 | 142461 | 无效的图像指针
142362 | 打开配置文件失败 | 142462 | 打开配置文件失败
142363 | LogC初始化错误 | 142463 | LogC初始化错误
142364 | LogC获取分类错误 | 142464 | LogC获取分类错误
142365 | 无效的网络命令 | 142465 | 无效的网络命令
142366 | 分类器文件名太长 |  |
142367 | 分类器文件不存在 |  |
142368 | 分类器文件名无效 |  |